OpenCms Documentation

Tested software versions

 Show GitHub edit links  Hide GitHub edit links
Documented since: 9.5 Latest revision for: 10.5 Valid for OpenCms: 11.0.2

To run OpenCms you need

  • a Java SE Development Kit (JDK)
  • a database management system (DBMS)
  • a servlet container

Here we give an overview of versions of these software components on which OpenCms 10.5 has been tested.

That does not mean that you are tied to these versions, but they are recommended.

JDK

OpenCms runs with a JDK for Java 8 and greater. It is tested with OpenJDK and Oracle JDK  for Java 8 and 11.

DBMS

OpenCms can connect to several different database management systems. The list provides an overview of the various provided database connectors and the DBMS versions for which the connectors are tested. Probably the connectors work also for newer versions of the DBMSs.

Only the connectors that are displayed bold are officially supported by Alkacon Software GmbH, the main developer of OpenCms.
  • MySQL Community Server/MariaDB >= 5.5 (recommended)
  • Oracle
    • Oracle 9i (tested)
    • Oracle 10g (tested)
    • Oracle 11g (tested)
    • later versions (untested)
  • PostgreSQL
    • PostgreSQL 7.4.x (tested)
    • PostgreSQL > 7.4.x (untested)
  • MS SQL Server
    • MS SQL Server 2000 (tested)
    • MS SQL Server 2005 (tested)
    • MS SQL Server 2008 R2 (tested)
    • later versions (untested)
  • DB2
    • DB2 9.7.x (tested)
  • AS400
  • HSQLDB
    • HSQLDB >= 1.8.0 (tested)

Servlet container

OpenCms requires a Servlet 3.1 / JSP 2.3 standards compliant container. It should work with every servlet container fulfilling these requirements.

  •  Tomcat
    • Tomcat 8.0 (tested)
    • Tomcat 8.5 (recommended)
    • Tomcat 9.0 (tested)

You can improve this page

Please contribute your suggestions or comments regarding this topic on our wiki. For support questions, please use the OpenCms mailing list or go for professional support.